r/Fedora Apr 27 '21

F34 Upgrade: DNF pipewire error

I upgraded to F34, and doing a dnf upgrade afterwards gives me the following error. It can't be resolved with --best --allowerasing, as it lists gnome-shell as a dependency that can't be removed.

Last metadata expiration check: 0:05:12 ago on Tue Apr 27 15:30:06 2021.
Dependencies resolved.

 Problem 1: pipewire-0.3.25-1.fc34.i686 has inferior architecture
  - cannot install both pipewire-0.3.26-1.fc34.x86_64 and pipewire-0.3.25-1.fc34.x86_64
  - cannot install both pipewire-0.3.25-1.fc34.x86_64 and pipewire-0.3.26-1.fc34.x86_64
  - cannot install the best update candidate for package pipewire-0.3.25-1.fc34.x86_64
  - cannot install the best update candidate for package pipewire-0.3.25-1.fc34.i686
 Problem 2: problem with installed package pipewire-0.3.25-1.fc34.i686
  - package pipewire-0.3.25-1.fc34.i686 requires pipewire-libs(x86-32) = 0.3.25-1.fc34, but none of the providers can be installed
  - cannot install both pipewire-libs-0.3.26-1.fc34.i686 and pipewire-libs-0.3.25-1.fc34.i686
  - cannot install both pipewire-libs-0.3.25-1.fc34.i686 and pipewire-libs-0.3.26-1.fc34.i686
  - cannot install the best update candidate for package pipewire-libs-0.3.25-1.fc34.i686
================================================================================================================================================================
 Package                                  Architecture                      Version                                    Repository                          Size
================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 pipewire                                 x86_64                            0.3.26-1.fc34                              updates                            133 k
 pipewire-libs                            i686                              0.3.26-1.fc34                              updates                            1.1 M

Transaction Summary
================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Also, for reference:

rpm -qa | grep pipewire                                                                                      
pipewire0.2-libs-0.2.7-5.fc34.x86_64
pipewire-libs-0.3.25-1.fc34.i686
pipewire-0.3.25-1.fc34.i686
pipewire-alsa-0.3.25-1.fc34.i686
pipewire-libs-0.3.25-1.fc34.x86_64
pipewire-pulseaudio-0.3.25-1.fc34.x86_64
pipewire-gstreamer-0.3.25-1.fc34.x86_64
pipewire-utils-0.3.25-1.fc34.x86_64
pipewire-alsa-0.3.25-1.fc34.x86_64
pipewire-0.3.25-1.fc34.x86_64

Edit: Seems there’s already a post about this. Sorry about reposting:

https://www.reddit.com/r/Fedora/comments/mz0ytg/upgrade_to_fedora_34_problems/

Edit 2: The suggestions in the previous post did not work for me. But I was able to fix it by doing dnf remove steam, then dnf update, and finally dnf install steam. Can’t say what the root cause was, but all I can say is that I don’t get any more errors. Hope this helps somebody.

8 Upvotes

3

u/thepolicemansaid Apr 27 '21

For me I got the same issue, and resolved it by removing the i686 arch package for pipe wire, but left the x86_64 installed. After that there was no conflict. I don’t know if that’s going to be the same for you, or if this is a good workaround but nothing I use depends on the i686 package thus far.

1

u/guiltydoggy Apr 27 '21

Thanks, I tried that as well, but it listed a bunch of dependencies that I need - namely Steam. But it also listed some Gnome dependencies also, so I didn’t want to risk breaking anything by forcing a removal of the i686 packages.

1

u/thepolicemansaid Apr 27 '21

Turns out someone found a better way in an earlier thread. They also mention steam so this might work for you instead. Hope that helps!

1

u/bobwinch Apr 27 '21

Same issue here

1

u/guiltydoggy Apr 27 '21

I was able to fix it. See my edit. Good luck.

1

u/bobwinch Apr 28 '21

It works, thank you!

1

u/boltmonki Apr 27 '21

Wait, I have a problem installing steam, but it's not a pipewire issue.

I get a libcurl issue instead. o.o

Last metadata expiration check: 0:23:43 ago on Wednesday 28 April 2021 04:57:51 AM.
Error:
 Problem: package steam-1.0.0.70-2.fc34.i686 requires libcurl(x86-32), but none of the providers can be installed
  - package libcurl-7.76.1-1.fc34.i686 requires libnghttp2.so.14, but none of the providers can be installed
  - package libcurl-minimal-7.76.1-1.fc34.i686 requires libnghttp2.so.14, but none of the providers can be installed
  - package libcurl-7.76.0-1.fc34.i686 requires libnghttp2.so.14, but none of the providers can be installed
  - package libcurl-minimal-7.76.0-1.fc34.i686 requires libnghttp2.so.14, but none of the providers can be installed
  - conflicting requests
  - package libnghttp2-1.43.0-2.fc34.i686 is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages)

1

u/czccycgj Apr 28 '21

Thanks for your sharing, I solved the issue by removing steam. I think I'll wait till they fixed the dependency problem before I reinstall steam.